summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-06-18 21:47:52 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-06-25 15:51:11 -0400
commit4f557036253ac5750576c88e5b9a86759a49d247 (patch)
tree220caae6a2d4010eb90c60e618b615f963d63982 /Makefile.am
parent1e9b958a096682b1ec111d400bd25048e3f95ed4 (diff)
downloadxorg-lib-libxtrans-4f557036253ac5750576c88e5b9a86759a49d247.tar.gz
config: XORG_WITH_GROFF: use HAVE_GROFF_HTML conditional
Groff uses grohtml to generate html output format. This program, in turn, uses a number of pnm* commands from the netpbm package, psselect from the psutils package and the ghostscript package. These are independently installed, so they could be missing. Skip the HTML output format if one of the dependencies is missing. The version 1.9 of the util-macros package is required. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 928614c..493bcc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,8 +42,11 @@ printable_format = .ps
endif
doc_DATA = $(doc_sources:.mm=.txt) \
- $(doc_sources:.mm=$(printable_format)) \
- $(doc_sources:.mm=.html)
+ $(doc_sources:.mm=$(printable_format))
+
+if HAVE_GROFF_HTML
+doc_DATA += $(doc_sources:.mm=.html)
+endif
CLEANFILES = $(doc_DATA)
MOSTLYCLEANFILES = index.*