summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-06-26 13:06:22 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-06-26 13:08:41 -0400
commit7761846c7fd97f15d7207e1b9fd9d42c9e58a0c4 (patch)
treed258ef4d1018239713e0b7a86b52a78e489f3c22 /Makefile.am
parent4f557036253ac5750576c88e5b9a86759a49d247 (diff)
downloadxorg-lib-libxtrans-7761846c7fd97f15d7207e1b9fd9d42c9e58a0c4.tar.gz
doc: replace groff input format with docbook xml format
Initial version of xtrans docbook xml. Requires util-macros 1.10 Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 3 insertions, 50 deletions
diff --git a/Makefile.am b/Makefile.am
index 493bcc5..9ff1723 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS=doc
+
Xtransincludedir = $(includedir)/X11/Xtrans
Xtransinclude_HEADERS = \
Xtrans.h \
@@ -16,8 +18,7 @@ pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = xtrans.pc
MAINTAINERCLEANFILES = ChangeLog INSTALL
-EXTRA_DIST = ${aclocal_DATA} Xtrans.mm
-
+EXTRA_DIST = ${aclocal_DATA}
.PHONY: ChangeLog INSTALL
@@ -28,51 +29,3 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog INSTALL
-
-# Rules to convert documentation from troff to other formats
-doc_sources = Xtrans.mm
-
-if ENABLE_DOCS
-if HAVE_GROFF_MM
-
-if HAVE_PS2PDF
-printable_format = .pdf
-else
-printable_format = .ps
-endif
-
-doc_DATA = $(doc_sources:.mm=.txt) \
- $(doc_sources:.mm=$(printable_format))
-
-if HAVE_GROFF_HTML
-doc_DATA += $(doc_sources:.mm=.html)
-endif
-
-CLEANFILES = $(doc_DATA)
-MOSTLYCLEANFILES = index.*
-
-# Pass version string as a troff string for substitution
-GROFF_DEFS = -dxV="$(PACKAGE_STRING)"
-
-# -t to run through tbl
-GROFF_FLAGS = -t -mm $(GROFF_DEFS)
-
-SUFFIXES = .mm .ps .txt .html .pdf
-
-.mm.ps:
- -$(AM_V_GEN) $(GROFF) -Tps $(GROFF_FLAGS) $< 2> index.$@.raw > $@
- @if grep '^[^1-9.]' index.$@.raw | grep -v warning; then exit 1; \
- else test $$? -le 1; fi
-
-.mm.txt:
- $(AM_V_GEN) env GROFF_NO_SGR=TRUE $(GROFF) -Tutf8 $(GROFF_FLAGS) \
- $< 2> index.$@.raw > $@
-
-.mm.html:
- $(AM_V_GEN) $(GROFF) -Thtml $(GROFF_FLAGS) $< 2> index.$@.raw > $@
-
-.ps.pdf:
- $(AM_V_GEN) $(PS2PDF) $< $@
-
-endif HAVE_GROFF_MM
-endif ENABLE_DOCS