summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2016-06-24 13:46:02 +1000
committerRichard Jones <r1chardj0n3s@gmail.com>2016-06-24 13:51:55 +1000
commit5fc34187e1c48deee5c3727de4619960c6863369 (patch)
treefa3621ed5012047397e8c9b91cbff283f1d678a0
parent6a9182ab0001215cf5f0c41356f98c88202f48e7 (diff)
downloadxstatic-angular-bootstrap-5fc34187e1c48deee5c3727de4619960c6863369.tar.gz
Include more metadata in setup.py
This uses the newer 1.1.0 version of xstatic-release which copies more information into setup.py and therefore into pypi. This change will also be used to test releasing through the openstack-release system. Change-Id: I036c1ce0b74212e74dffa853e709db086a4829be
-rw-r--r--setup.py9
-rw-r--r--xstatic/pkg/angular_bootstrap/__init__.py2
2 files changed, 10 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b680c15..f711472 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,15 @@
from setuptools import setup, find_packages
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
setup(
name='XStatic-Angular-Bootstrap',
+ summary="""Angular-Bootstrap 0.11.0 (XStatic packaging standard)""",
+ description=long_description,
+ maintainer="Maxime Vidori",
+ maintainer_email='maxime.vidori@enovance.com',
use_scm_version=True,
setup_requires=['setuptools_scm', 'wheel'],
packages=find_packages()
diff --git a/xstatic/pkg/angular_bootstrap/__init__.py b/xstatic/pkg/angular_bootstrap/__init__.py
index b8b04e7..1f6c4ad 100644
--- a/xstatic/pkg/angular_bootstrap/__init__.py
+++ b/xstatic/pkg/angular_bootstrap/__init__.py
@@ -13,7 +13,7 @@ NAME = __name__.split('.')[-1] # package name (e.g. 'foo' or 'foo_bar')
VERSION = '0.11.0' # version of the packaged files, please use the upstream
# version number
-BUILD = '4' # our package build number, so we can release new builds
+BUILD = '5' # our package build number, so we can release new builds
# with fixes for xstatic stuff.
PACKAGE_VERSION = VERSION + '.' + BUILD # version used for PyPi