summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Cresswell <robert.cresswell@outlook.com>2016-05-10 15:01:42 +0100
committerRob Cresswell <robert.cresswell@outlook.com>2016-07-14 09:50:27 -0700
commit830746ff6d09fed0417ab488549604f36829d5b0 (patch)
treec663b9f7d874c1032680032682ea16269172768e /setup.py
parente0fbf69fb156b995547471d71c5c6a7f88989d47 (diff)
downloadxstatic-angular-smart-table-830746ff6d09fed0417ab488549604f36829d5b0.tar.gz
Update Smart-Table to 1.4.131.4.13
This is the latest release for 1.x. Moving to this version for now, will investigate 2.x later Also adds several missing files so that the package is consistent with the other xstatic packages. Change-Id: Icaa3f5099beb66edc4e83feeb2a9d8e3315a8895
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 9 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index d7ecd21..47062a9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,17 @@
-
-from xstatic.pkg import angular_smart_table as xs
+from setuptools import setup, find_packages
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
-from setuptools import setup, find_packages
-
setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
+ name='XStatic-smart-table',
+ summary="""smart-table 1.4.13 (XStatic packaging standard)""",
+ description=long_description,
+ maintainer="Richard Jones",
+ maintainer_email='r1chardj0n3s@gmail.com',
+ use_scm_version=True,
+ setup_requires=['setuptools_scm', 'wheel'],
packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[],
+ include_package_data=True
)