summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Cresswell <robert.cresswell@outlook.com>2016-07-18 09:29:01 +0100
committerRob Cresswell <robert.cresswell@outlook.com>2016-07-19 08:17:20 +0100
commit5a30bee80d67c0f26ecbf05726f4838dbae3f276 (patch)
treec014982322454fd386d38226b01dccd4d64533f5 /setup.py
parentd0dd552b6026a5c153180a68b217830425c7d352 (diff)
downloadxstatic-angular-5a30bee80d67c0f26ecbf05726f4838dbae3f276.tar.gz
Update with xstatic-release script1.4.10.1
Change-Id: I85514e4afde528e72d8b2a44a79702427df449f3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 10 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index b2774f3..4fb31b4 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,17 @@
-from xstatic.pkg import angular as xs
+from setuptools import setup, find_packages
# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
+# it to generate your project's PyPI page.
long_description = open('README.txt').read()
-from setuptools import setup, find_packages
-
setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
+ name='XStatic-Angular',
+ summary="""Angular 1.4.10 (XStatic packaging standard)""",
+ description=long_description,
+ maintainer="Rob Cresswell",
+ maintainer_email='robert.cresswell@outlook.com',
+ use_scm_version=True,
+ setup_requires=['setuptools_scm', 'wheel'],
packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
+ include_package_data=True
)