summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-07 12:55:29 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-07 12:55:29 +0200
commit15b8b62ac20add6de8954053335487a7a492a462 (patch)
tree224186f14909e39f5f1ea6c8d3d23f6976e677eb /Makefile.am
parentcbd1a6049adbbc21081104a1cb7c2b793652106a (diff)
parentea93d8d05cf61d11a557e21b47f4736e337f6b1a (diff)
downloadautomake-15b8b62ac20add6de8954053335487a7a492a462.tar.gz
Merge branch 'maint'
* maint: tests: move 'runtest' into the top-level directory
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index a396d8f3d..8e6689437 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -400,16 +400,16 @@ defs-static: defs-static.in Makefile
EXTRA_DIST += defs-static.in
CLEANFILES += defs-static
-t/ax/runtest: t/ax/runtest.in Makefile
+runtest: runtest.in Makefile
$(AM_V_at)rm -f $@ $@-t
- $(AM_V_GEN)in=t/ax/runtest.in \
+ $(AM_V_GEN)in=runtest.in \
&& $(MKDIR_P) t/ax \
- && $(do_subst) <$(srcdir)/t/ax/runtest.in >$@-t \
+ && $(do_subst) <$(srcdir)/runtest.in >$@-t \
&& chmod a+x $@-t
$(generated_file_finalize)
-EXTRA_DIST += t/ax/runtest.in
-CLEANFILES += t/ax/runtest
-noinst_SCRIPTS = t/ax/runtest
+EXTRA_DIST += runtest.in
+CLEANFILES += runtest
+noinst_SCRIPTS = runtest
# If two test scripts have the same basename, they will end up sharing
# the same log file, leading to all sort of undefined and undesired