summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-11-16 23:21:18 +0700
committerGary V. Vaughan <gary@gnu.org>2011-11-25 14:53:41 +0700
commita53d6cc4983d5c274b9db259835af12c12842a6b (patch)
tree51274d0d1d4588dfe7977c749948b49884500a53 /configure.ac
parent06c6555d4a77a5e91f43da3451586534da93e0ae (diff)
downloadlibtool-a53d6cc4983d5c274b9db259835af12c12842a6b.tar.gz
tests: migrate tests/sh.test checks to syntax-checks.
Some modernization of the legacy testsuite. * tests/sh.test: Remove. * Makefile.am (COMMON_TESTS): Adjust. * cfg.mk (sc_libtool_m4_cc_basename, sc_prohibit_bracket_as_test) (sc_prohibit_nested_quotes, sc_prohibit_set_dummy_without_shift) (sc_prohibit_set_minus_minus, sc_prohibit_test_binary_operators) (sc_prohibit_test_dollar, sc_prohibit_test_minus_e) (sc_prohibit_test_unary_operators, sc_prohibit_test_X) (sc_prohibit_Xsed_withou_X, sc_require_function_nl_brace): Functionally identical tests to what used to be performed by sh.test, only with coverage of all files. * bootstrap, build-aux/edit-readme-alpha, build-aux/extract-trace, build-aux/getopt.m4sh, build-aux/ltmain.m4sh, configure.ac, m4/libtool.m4, m4/ltdl.m4, tests/bindir.at, tests/configure-iface.at, tests/cwrapper.at, tests/darwin.at, tests/defs.m4sh, tests/demo-hardcode.test, tests/dlloader-api.at, tests/exceptions.at, tests/getopt-m4sh.at, tests/lalib-syntax.at, tests/link-2.test, tests/link-order2.at, tests/loadlibrary.at, tests/lt_dladvise.at, tests/lt_dlexit.at, tests/lt_dlopen_a.at, tests/lt_dlopenext.at, tests/need_lib_prefix.at, tests/nonrecursive.at, tests/recursive.at, tests/resident.at, tests/standalone.at, tests/static.at, tests/stresstest.at, tests/subproject.at, tests/sysroot.at, tests/tagtrace.test, tests/testsuite.at: Fix violations of the new syntax checks. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 39d06f47..5fe1cb84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,7 +114,7 @@ AC_SUBST([pkgdatadir], ["\${datadir}/$PACKAGE"])
AC_ARG_ENABLE(ltdl-install,
[AS_HELP_STRING([--disable-ltdl-install], [do not install libltdl])])
-if test x"${enable_ltdl_install+set}" != xset; then
+if test "x${enable_ltdl_install+set}" != xset; then
enable_ltdl_install=yes
fi
@@ -200,7 +200,7 @@ END
cd ..
rm -rf conftest.dir
])
-if test $lt_cv_make_order_only = yes; then
+if test yes = "$lt_cv_make_order_only"; then
ORDER='|'
else
ORDER=''