summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-16 15:49:08 +0800
committerPetr Štetiar <ynezz@true.cz>2023-05-16 16:33:20 +0200
commit466be0612aaed4034e15095b9fc63ce4cd99b87a (patch)
tree31984d31903be0f5a382cd993f61e010ce82dd42
parent8f455f7c5e0c1fe7c8c2297a2fa4b2a6c7d6c91e (diff)
downloadopenwrt-466be0612aaed4034e15095b9fc63ce4cd99b87a.tar.gz
e2fsprogs: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces and autotools failed to check the lseek64 function. Force enable ac_cv_func_lseek64 to workaround it. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
-rw-r--r--package/utils/e2fsprogs/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 9437947ab6..42c2971529 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_VERSION:=1.47.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/tytso/e2fsprogs/v$(PKG_VERSION)/
@@ -156,6 +156,10 @@ CONFIGURE_ARGS += \
--disable-rpath \
--disable-fuse2fs
+ifneq ($(CONFIG_USE_MUSL),)
+ CONFIGURE_VARS += ac_cv_func_lseek64=yes
+endif
+
define Build/Prepare
$(call Build/Prepare/Default)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/config/