summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2021-06-14 21:57:29 +0200
committerMatěj Cepl <mcepl@cepl.eu>2021-06-14 21:59:42 +0200
commit8b0fa1626ca0ecd33aa56119f4be90087c7bac4a (patch)
treeba27a2aebb97cd5fee3dd9c393c1341c5ea66f90
parent3cbab82d7cc31c4c489c2054c3b4b62a633fee71 (diff)
downloadm2crypto-8b0fa1626ca0ecd33aa56119f4be90087c7bac4a.tar.gz
Remove the last use of setup.py test idiom.
-rw-r--r--INSTALL.rst2
-rw-r--r--appveyor.yml2
-rw-r--r--tests/README4
3 files changed, 4 insertions, 4 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index f0fb954..776b704 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -35,7 +35,7 @@ with Cygwin are welcome).::
If you have installed setuptools you can also optionally run tests like
this:::
- $ python setup.py test
+ $ python -munittest discover -v tests
This assumes OpenSSL is installed in ``/usr``. You can provide an
alternate OpenSSL prefix location with --openssl option to
diff --git a/appveyor.yml b/appveyor.yml
index c617bf6..eabda21 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -162,7 +162,7 @@ build_script:
- "%PYTHON%\\python.exe setup.py build --openssl=\"%OPENSSL_PATH%\" --bundledlls"
test_script:
- - "%PYTHON%\\python.exe setup.py test"
+ - "%PYTHON%\\python.exe -munittest discover -v tests"
after_test:
# If tests are successful, create a whl package for the project.
diff --git a/tests/README b/tests/README
index 28eac67..d3b27aa 100644
--- a/tests/README
+++ b/tests/README
@@ -3,11 +3,11 @@ This directory contains unit tests for M2Crypto.
To run all tests, make sure you have installed setuptools and then issue the
following command from the M2Crypto root directory:
-python setup.py test
+python -munittest discover -v tests
To run tests in a single file, for example test_ssl.py, do this:
-python setup.py test --test-suite=tests.test_ssl
+python -munittest -v tests.test_ssl
Look also in the demo directory for other samples.