summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-04-16 14:55:15 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-04-16 14:55:15 +0200
commit51cd8470eee87d8f69226a58f73e29e2ddad794a (patch)
tree21055e0dd69e137c8795f2694833d83dc911ff70 /Makefile
parent6ab8a54615ddb9c2f6287047686e3f5b063440ba (diff)
downloadpsutil-51cd8470eee87d8f69226a58f73e29e2ddad794a.tar.gz
update doc
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a3075012..dc18e62e 100644
--- a/Makefile
+++ b/Makefile
@@ -197,7 +197,7 @@ check-imports: ## Run isort linter.
check-c-code: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py
-lint: ## Run all linters
+check-all: ## Run all linters
${MAKE} check-flake8
${MAKE} check-imports
${MAKE} check-c-code
@@ -213,6 +213,10 @@ fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg
+fix-all:
+ ${MAKE} fix-flake8
+ ${MAKE} fix-imports
+
# ===================================================================
# GIT
# ===================================================================