summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-12-07 22:44:08 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-12-08 16:52:29 +0100
commitb941fdf737d1db375ac484199d39f60f268262d2 (patch)
treec8e02a2a485cb128fdf40629f7e13bb267f25fdf /.pre-commit-config.yaml
parentb375bb2762fd579e82f85955d9cc1503bdec25e1 (diff)
downloadpylint-git-b941fdf737d1db375ac484199d39f60f268262d2.tar.gz
[pre-commit] Add pyroma to the configuration
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml14
1 files changed, 14 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index b13f5112d..15d6a71d2 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -132,3 +132,17 @@ repos:
exclude: *fixtures
args: ["--max-summary-lines=2", "--linewrap-full-docstring"]
files: "pylint"
+ - repo: https://github.com/regebro/pyroma
+ rev: "4.1"
+ hooks:
+ - id: pyroma
+ # Must be specified because of the default value in pyroma
+ always_run: false
+ files: |
+ (?x)^(
+ README.rst|
+ pyproject.toml|
+ pylint/__init__.py|
+ pylint/__pkginfo__.py|
+ setup.cfg
+ )$