summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-19 12:58:41 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-19 13:17:13 -0400
commitfe9756d3ab2e4a1efb98418e2a90e7ec7763eab1 (patch)
treed9aaa942632c34db9e625d758c9a1eb1c7f26ca3
parent3f9386a4359219991dba3fd5f770f348270e178b (diff)
downloadpython-systemd-fe9756d3ab2e4a1efb98418e2a90e7ec7763eab1.tar.gz
Makefile: add convenience "shell" target to start python shell
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index b34f251..678f412 100644
--- a/Makefile
+++ b/Makefile
@@ -70,4 +70,8 @@ upload: dist/systemd-python-$(VERSION).tar.gz dist/systemd-python-$(VERSION).tar
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+
-.PHONY: build install dist sign upload clean distclean TAGS doc doc-sync
+shell:
+# we change the directory because python insists on adding $CWD to path
+ (cd $(builddir) && $(PYTHON))
+
+.PHONY: build install dist sign upload clean distclean TAGS doc doc-sync shell