summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-26 17:58:47 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 15:39:11 -0700
commit4335c55ea6848665969c17a8bf19bdf39be3758b (patch)
treed1b95367527403c6e50453c2b83633294e9b9d77 /test/Makefile.am
parent18c9c8968c91224df16cb06cd798a4ba6893b632 (diff)
downloadxorg-lib-libXmu-4335c55ea6848665969c17a8bf19bdf39be3758b.tar.gz
test: Add simple test cases for functions in src/StrToJust.c
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 05940e5..8091faf 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -36,7 +36,8 @@ check_PROGRAMS = \
Lower \
ReadBitmapData \
StrToBS \
- StrToGrav
+ StrToGrav \
+ StrToJust
TESTS = $(check_PROGRAMS)
TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
@@ -65,6 +66,9 @@ StrToBS_LDADD = $(XMU_TEST_LIBS)
StrToGrav_SOURCES = StrToGrav.c
StrToGrav_LDADD = $(XMU_TEST_LIBS)
+StrToJust_SOURCES = StrToJust.c
+StrToJust_LDADD = $(XMU_TEST_LIBS)
+
endif HAVE_GLIB
endif ENABLE_UNIT_TESTS